OS X Yosemite WiFi Problems

After upgrading to Yosemite 10.10 from Mavericks, wifi problems are bugging me to death on my MacBook Air.

Wifi doesn’t show a disconnect, but a disconnect is occurring intermittantly.  Applications using an internet connection are stalling, waiting for a reconnect (Messages, Safari, Chrome, Gmail, etc.).

Is anyone else experiencing this problem?

Looks like a good thread going on at Apple Discussions

Update 10/22/2014: I performed a “safe boot” on my mac tonight as described by Topher Kessler at MacIssues. I’ll let you know how that affects the wifi disconnect problem.

It appears that the safe boot didn’t correct the wifi dropout problem. Here’s another news article about the problem which Apple isn’t discussing.

Update 10/30/2014: I successfully performed a procedure described in step 1 at OSX Daily. I’ll let you know if this resolves the wifi problem I’ve been talking about.

Update 10/31/2014: I’m still experiencing the wifi problem. Sigh.

Update 11/04/2014 I changed my wifi MTU setting from 1500 to 1453. I haven’t noticed any negative effects of the change. I’ll let you know if it stabilizes my wifi connection.

Update 11/08/2014 I’m still experiencing the wifi problem. Another idea anyone?

Update 11/17/2014 Apple has released Yosemite update 10.10.1 that it says improves Wi-Fi reliability. Go to the App store and download this important update. Here is a link to the Knowledge Base article: Yosemite 10.10.1 knowledge base article

I’ve installed the update and will post later about its effect on the wifi problems I have been experiencing.

Update 11/24/2014 Wi-Fi is still dropping, but it doesn’t seem as bad as it was. Oh well, sigh…

Update 3/5/2015 For the most part, Apple’s last update seems to have fixed my problem. Still the occasional problem, but nothing like before. I’m a much happier camper now, so to speak.

Please follow and like us:

4 Replies to “OS X Yosemite WiFi Problems”

  1. Yes, I have the same problem since upgrading. Safari are stalling occasionally, if I switch between wifi-networks connection seem to come back.

    1. I haven’t noticed the problem so much the last few days. I have noticed that the mouse cursor will sometimes disappear from the login screen when switching between users.

Comments are closed.